System Requirements

Web App

PagerDuty's web app requires a modern web browser with JavaScript enabled.

We recommend using the most recent production release of the browser(s) you work in. Older versions and pre-release browsers, such as betas or developer previews, are not supported. Issues with a pre-release version of a browser should be reported to the browser vendor.

Browser extensions, such as ad or JavaScript blockers, can interfere with or completely prevent certain features from working correctly, and are not supported. We recommend safelisting *.pagerduty.com in these extensions so that they won't prevent you from accessing and using PagerDuty web apps.

The following browsers are tested and supported:

BrowserSupported Version(s)
Apple Safari9 and higher
Google Chromelatest stable version
Microsoft Edgelatest stable version
Microsoft Internet Explorer**11**
Mozilla Firefoxlatest stable version
Operalatest stable version

🚧

** Microsoft Internet Explorer 11 Support

At the end of 2020, PagerDuty will be removing support for Microsoft Internet Explorer 11.

Mobile Apps

We support the latest version of the PagerDuty app available from the Apple App Store or Google Play Store on devices running iOS 11 and higher or Android 5.0 and higher. For more information, see Using the Mobile App.

Integrations

System requirements for integrations are listed in the integration guide.

Updated 8 days ago

System Requirements


Suggested Edits are limited on API Reference Pages

You can only suggest edits to Markdown body content, but not to the API spec.